Skip to main content
November 13, 2018 ...

News

  • Please note: 101user.com is in no way affiliated with 101Hero. 101user.com is an unofficial user forum.

Topic: NMEA17 steppers just hum and spit (Read 418 times) previous topic - next topic

  • rcojoe
  • [*][*]
NMEA17 steppers just hum and spit
Hey guys.  I am replacing my steppers with NEMA17 motors but before I wire it all up,  I decided to wire one stepper up and make sure the motor test works. 

I plugged everything in, as well as plugged one of the original steppers into the B plug on the controller, then plugged one of the new steppers into the C port on the controller.

When I ran the test, the motor just hums and jerks a bit.  So I tried it with another nema 17 stepper i have, and it did the same thing.  The original stepper spins smooth and perfect.

The nema 17 steppers are good, I have used them on various other projects, and I'm hooking up all but the red wire into the C port, so  it should work there.  I'm using the original power supply, and i know i won't be able to when I get it all hooked up, but it should be enough to run one servo.   

I tried it with and without the M92 X100 Y100 Z100 command to adjust for the new steppers. 


The motor just bucks and kicks,  It almost sounds like only one side of the coils are firing but that's impossible since there are only 4 wires and if its moving at all, that means that one coil is wired right, so it is all wired right.

What am I doing wrong?

Joe
  • Last Edit: 11 Apr, 2017, 05:17:06 AM by rcojoe

  • rcojoe
  • [*][*]
Re: NMEA17 steppers just hum and spit
Reply #1
Solved it myself after 5 hours of playing with this.  I had to swap the outside wires on my new steppers.

Joe