Skip to main content
March 20, 2018 ...


  • .stl, .gcode and .123dx files can now be uploaded as attatchments


What problems has your hero had

  • Motors
    26 (42.6%)
  • Power supply
    3 (4.9%)
  • SD card reader
    5 (8.2%)
  • Controller
    5 (8.2%)
  • Bearings and/or guides
    7 (11.5%)
  • Other
    14 (23%)
  • No problems
    1 (1.6%)

Total Members Voted: 44

Voting closed: 09 Jan, 2017, 13:37:37 PM

Topic: What problems have you experienced  (Read 1055 times) previous topic - next topic

  • Admin
  • [*][*][*][*][*]
  • Administrator
What problems have you experienced
What problems has your Hero experienced.

You can select 2 options. 

Guests can also vote in this poll.

If you select other please explain in a reply ;)
  • Last Edit: 10 Dec, 2016, 13:47:12 PM by Admin

Re: What problems have you experienced
Reply #1
The problems I've had so far are:
Calibration. It is really hard to access those screws without stripping them. On the one hand I want to replace them, on the other I don't want to make my setup worse. I'm currently getting functional prints. I wish they were better, but as is I think I can use this to bootstrap some variety of reprap.

Software. Specifically drivers. My laptop is running Arch linux and compiling the drivers isn't straightforward. So instead of using the usb connection I've been exporting the gcode from cura to an SD card and printing that way.

  • byrde72
  • [*][*]
Re: What problems have you experienced
Reply #2
Calibration. I'm so close, but the screws are so stripped I need to replace them with M3 by 12mm and start over,

Re: What problems have you experienced
Reply #3
I have 1 stepper that's not playing ball

2 are nice and smooth, the last one (B) seems to have no torque and it's very notchy...   when I take it out of the printer equation laying flat on table it seems to work as expected but when I put it back into vertical on and the printhead attached, not moving the way it should be, throwing off any chance of real printing

Re: What problems have you experienced
Reply #4
The greatest problem I am facing is their support.
As I was talking to them (Zoe and Alice ) through email they can suddenly stop
replying to me.
I am very disappointed that this is how they treat their backer eho has put in faith to
back them. :'(

Re: What problems have you experienced
Reply #5
My hero did not have any problem. The motor also moved, the glass plate was not broken, and the color specified was correct. I did not know where the delivery company belongs to the tracking number, but such a thing was trivial. Because the door bell rang as soon as surprised. :o
However, the printed object was a "The thing"! :-X
After two "The things" were born, I tried to print a decent thing, but since the temperature of the hot end does not go up at all, printing does not start. This is not a problem of a hero. The problem is the season. I concluded that it is to warm up the printer to solve the problem.

  • Admin
  • [*][*][*][*][*]
  • Administrator
Re: What problems have you experienced
Reply #6
@shimomokiri , have you checked the thermesistor on the hot end. I've heard of at least one hot end where the thermosister was not working properly and caused problems with the hot end.

Re: What problems have you experienced
Reply #7
@Admin ,In CURA's display, it was warm at around 63 ° C, so it seems there was no sign of breakdown of the hot end area, but I will investigate it a bit more.
Thank you.

Re: What problems have you experienced
Reply #8
My motors on the towers seem to work, but my extruder... It has feed issues.
How tight are you guys closing your door on your extruder?

I feel like mine gets too tight, or too loose if i back off the screws that hold the door shut.
Looking at my prints it seems like it's under extruding.

When I measure and mark 100mm of filament, then manually try to extrude 100mm in repteir, it does not extrude the full 100mm.

I measured a straw with my calipers and cut it to 100mm size, then slid the straw over the filment and marked it with a sharpie pen, and queued the first mark up with the top of the bowden tube on the the extruder. It seems to only feed about 3/4 of it, or ~75mm (rough estimate, i haven't measured it exactly).
  • Last Edit: 30 Dec, 2016, 21:29:12 PM by DigitalWhitewater

  • Admin
  • [*][*][*][*][*]
  • Administrator
Re: What problems have you experienced
Reply #9
@DigitalWhitewater , I think that's a 'feature' of the printer to be honest. A few people have been taking about under extrusion.
I think @David .ini file in the benchy thread helps to reduce this.

Re: What problems have you experienced
Reply #10
You're probably right about being a 'feature'.

I have David's .ini file. I just haven't tried slicing my own models using it yet.
Hopefully over the weekend i'll have time to do so.

  • Bohemian
  • [*][*]
Re: What problems have you experienced
Reply #11
I was shipped two pylons with "A" stepper motors and two "J" limit switches. I plugged the 2nd identical pylon into the "B" and "I" ports.

My machine will not do anything but hum and after about 60-120 seconds the small e-fan on the extruder begins to spin. The machine simply does nothing.

This may be a tell as to what is wrong but, when I try and connect via USB my laptop says unable to connect to USB device. The USB port shows a trouble code, as if it sees something is connected, but something is badly wrong with it.

I think my motor controller is just flat broken, but I haven't seen anyone have a solid diagnosis or repair.

  • Admin
  • [*][*][*][*][*]
  • Administrator
Re: What problems have you experienced
Reply #12
The usb problem does not seem to be that unusual,  people are experiencing problems with it on a regular basis, some are saying that it's the type of cable, some find that changing ports solves the problem etc.
If it's sending an error it can see something there. Have you installed the drivers?

The humming could be an indication of dead motors?
Try running the home and test programmes from

The fan on a 3d printer hot end usually takes a minute or 2 to kick in, it's used to control the temp of the hot end.

The hero is, to be blunt, temperamental and a lot of people are finding that getting it working requires a lot of trial and error.

  • Bohemian
  • [*][*]
Re: What problems have you experienced
Reply #13
The motors don't seem to be humming, only the extruder.

I have installed the driver. I downloaded all of the test files, and have tried each one. The machine just sits there, unmoved.

  • Admin
  • [*][*][*][*][*]
  • Administrator
Re: What problems have you experienced
Reply #14
Not sure what that could be.
It could be the heater plates heating. The hero has anot unusual heater which may cause noise.

As for the motors, check your SD card, if you look around the forum you will see that after changing sd card or formatting differently,  the printer motor begins to work.,35.0.html should shed some light on this.